Uploading Taxonomy to Workbench Problem

Home Forums User Forum Uploading Taxonomy to Workbench Problem

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Flic 10 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2172

    Flic

    Hello,

    Testing out Specify as a potential collections management software, have Specify 7 installed and running, now attempting to upload taxonomy data via workbench in the web interface.

    I am currently trying to upload family data so I can then upload within-family taxonomy easier, but I am having difficulty uploading the file.

    I get the following error from the log:

    pid = 15531
    2018-01-15T14:17:50Z: starting with args [Suppressed]…
    2018-01-15T14:17:50Z: Couldn’t create data directory for Specify [/var/www/Specify]
    2018-01-15T14:17:50Z: …exiting UN-successfully.
    log4j:ERROR setFile(null,true) call failed.
    log4j:ERROR setFile(null,false) call failed.

    I have Specify 7 in /var/www/html/specify7 and Specify 6 in /usr/local/Specify with no mention of /var/www/Specify anywhere. Does anyone know where this directory is referenced and can be changed please?

    Thanks in advance,
    Flic

    #2352

    anhalt

    Hello,

    I’ve not seen this particular issue before, but I suspect what may be happening is that the Specify process is running as the webserver user which typically has $HOME set to /var/www/. The Specify 6 code that is used by the workbench tries to write some logs and preferences in the $HOME/Specify subdirectory. I would check the apache.conf that sets up the Specify 7 instance. There should be a line similar to this line (https://github.com/specify/specify7/blob/master/specifyweb_apache.conf#L19) in the example conf file. Make sure the user specified there is a regular, non root or daemon user.

    Ben

    #2353

    Flic

    Thanks @Anhalt, I was indeed running Specify under the www-data account, and after creating a new user account for specify and updating the config, that problem is fixed.

    Thanks for your help!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.